Author Topic: Quelques problème avec fastboot sur Windows  (Read 11721 times)

Offline Pkthib

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
  • Karma: 0
    • View Profile
Quelques problème avec fastboot sur Windows
« on: August 27, 2011, 03:24:19 AM »
Bonjour à tous,
Je viens de recevoir mon nouveau téléphone, et bien sur, en faisant la mise à jour vers CM7, j'ai réussi à le briquer sur l'écran de CM7 (en fait, ROM Manager n'ayant pas trouvé le .zip sur la carte SD la première fois, j'avais déjà fait "wipe cache" et autres, j'ai redémarré le tél, et là ROM manager a trouvé le .zip. Mais j'ai pas recoché "wipe cache and user data" en me disant que c'était déjà fait...)
Et maintenant j'ai deux problèmes :
Pour commencer je n'arrive pas à installer les programmes qu'il faut pour fastboot. J'ai Android SDK et Platform Tools, mais il faut visiblement les drivers, que j'ai téléchargé, mais Windows (7, 64 bits) refuse de les installer... J'ai cru comprendre qu'il fallait installer QXDM, ce que j'ai fait aussi, j'ai même copié mes .dll dans les dossiers systèmes... mais j'arrive toujours pas à installer ces drivers. Je pourrais essayer (plus difficilement) sur Linux, mais j'ai pas compris la marche à suivre
Et puis deuxièmement, pour démarrer le téléphone en fastboot, faut il faire la manip après l'avoir démarré, ou pour le démarrer ? Parce que quand j'essaie de le démarrer comme ça il ne démarre pas, et si je fais la manip sur l'écran blanc geeksphone, il passe quand même à CM7

Merci de votre attention et de votre aide !
« Last Edit: August 28, 2011, 03:27:20 AM by Pkthib »

Offline EowynCarter

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 226
  • Karma: 5
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #1 on: August 27, 2011, 04:41:07 AM »
Le tel en mode fastboot n'affiche rien, écran noir.
Si tu vois apparaître "geeksphone zéro" c'est que le tel est pas en mode fastboot.

Coté windows, je peux pas trop t'aider, je suis linuxienne. Par contre, si tu as besoin d'aide avec linux.

Offline Pkthib

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
  • Karma: 0
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #2 on: August 27, 2011, 05:02:47 AM »
D'accord, merci !  :)

Si tu peux me dire ce que j'ai à faire avec Linux, j'ai un PC portable sous Fedora 14, j'y serais plus à l'aise qu'avec Windows pour la ligne de commande, mais il est un peu moins réactif (il est assez vieux) que mon PC Windows.

Offline Nicolarius

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 36
  • Karma: 0
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #3 on: August 27, 2011, 08:16:25 AM »
Mec! Mec! Les pilotes Windows fonctionnent également en 64 bits et je parie que tu les avais correctement installés.

Pilotes Windows NT: http://www.megaupload.com/?d=V0W1DLM9
SDK Android: http://dl.google.com/android/android-sdk_r12-windows.zip
Fastboot: http://developer.htc.com/adp.html

Une fois tout ceci installé, démarre ton Geeksphone en fastboot. Il doit être éteint, tu appuies sur la touche volume haut longuement et sans la relacher appuie longuement sur power. Rien ne s'affiche à l'écran, il semble éteint c'est normal.

Utilise l'interpréteur DOS de Windows pour lancer le fastboot en lien puis utilises la commande fastboot devices Si un périphérique est détecté avec un point d'interrogation, c'est bon ton Geeksphone est en fastboot.

Maintenant tu n'as plus qu'à faire mumuse avec fastboot et ses commandes. Genre flasher une ROM, effacer le cache et les userdata ou autre... Je pourrai t'en dire plus si tu le souhaites.

Retenez que... IL NE FAUT JAMAIS FAIRE DE WIPE DE QUOI QUE CE SOIT APRES L'APPLICATION D'UN .ZIP

On wipe avant, pas après. ;)

Offline Pkthib

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
  • Karma: 0
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #4 on: August 27, 2011, 09:08:24 AM »
En effet ! Après redémarrage de windows, les drivers ont bien voulu s'installer (puis j'ai confondu le téléphone avec un autre périphérique sans drivers, mais lui je sais pas d'où il sort (une carte PCI) donc je laisse tomber).
Mais quand je démarre le téléphone en fastboot, je le branche au PC ensuite (j'ai le son windows qui m'indique que le périphérique est détecté), puis je lance la commande, je vais dans le répertoire de fastboot/adb, et je n'ai aucun retour sur "fastboot devices".
Je réessayerai demain.

Merci beaucoup !

Offline Pkthib

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
  • Karma: 0
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #5 on: August 28, 2011, 03:26:52 AM »
Hé hé ! Merci à tous ! J'ai finalement réussi à flasher tout ça, sous Linux au final, j'ai fini par trouver la aussi comment faire (problèmes de permissions de fichiers). Donc ça remarche, et je suis bien content !
Merci encore de votre aide !

Offline Nicolarius

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 36
  • Karma: 0
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #6 on: August 29, 2011, 07:27:22 AM »
Parfait. A mon avis tous les utilisateurs de Geeksphone devraient apprendre à faire ça. ;)

Offline jna 30

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
  • Karma: 0
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #7 on: January 30, 2012, 03:28:55 AM »
bonjour imposible de me servire de fastboot ne fonctionne pas , mon zero reste bloquer sur le logo zero de la rom stock, quelqu un peu médé merci

Offline EowynCarter

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 226
  • Karma: 5
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #8 on: January 30, 2012, 04:18:51 AM »
Pourquoi fastboot ne fonctionne pas ?
Arrive tu a mettre ton tel en mode fastboot ?

Offline jna 30

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
  • Karma: 0
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #9 on: January 30, 2012, 04:33:03 AM »
je n arrive pa a le metre en fatboot pa moyen

Offline jna 30

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
  • Karma: 0
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #10 on: January 30, 2012, 05:23:53 AM »
mon tel ne veu pa se metre en mode fastboot comment faire merci

Offline Mosquito Fillano

  • Top Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1425
  • Karma: 38
  • ONE: CyanogenMod 7.1  ZERO: GZR 1.6
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #11 on: January 30, 2012, 05:52:21 AM »
Essayez ce qui suit:
- Branchez le câble USB à l'ordinateur, et non pas le téléphone
- Retirez la batterie du téléphone, attendre quelques secondes
- Mettez la batterie
- Appuyez sur le "vol Up", attendre 2 secondes
- Branchez le câble USB au téléphone, attendre 6 ou 7 secondes
- Relâchez le bouton "Vol Up"
- Sur un terminal d'ordinateur, "fastboot devices" devrait voir le point d'interrogation (?)
- Pardonnez mon français
  ...porque me gustó la iniciativa de Juan Gómez-Jurado

Offline jna 30

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
  • Karma: 0
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #12 on: January 30, 2012, 06:57:58 AM »
toujour rien sa ne marche pas , rien ne safiche sur cmd.exe

Offline jna 30

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
  • Karma: 0
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #13 on: January 30, 2012, 07:44:22 AM »
sur cmd.exe, sa me di fastboot né pa reconnu en tan que commande externe ou interne alor je n sai plu quoi faire

Offline Mosquito Fillano

  • Top Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1425
  • Karma: 38
  • ONE: CyanogenMod 7.1  ZERO: GZR 1.6
    • View Profile
Re: Quelques problème avec fastboot sur Windows
« Reply #14 on: January 30, 2012, 08:14:16 AM »
Traduction automatique, désolé:
http://forum.geeksphone.com/index.php?topic=1829.0


Vous devez installer les drivers pour Windows à ce fil.
Vous devez mettre les fichiers "*. img" dans le même répertoire que la commande fastboot.
Vous devez exécuter la commande fastboot partir du même répertoire.
  ...porque me gustó la iniciativa de Juan Gómez-Jurado