Author Topic: gp revolution fails to connect to Japan carrier NTT docomo  (Read 1265 times)

Offline shioyama

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
  • Karma: 0
    • View Profile
    • dejimata
gp revolution fails to connect to Japan carrier NTT docomo
« on: June 14, 2015, 01:33:14 AM »
Already posted in the gp revolution forum here: http://forum.geeksphone.com/index.php?topic=6510.0

I'm trying to connect to one of the major carriers here in Japan (NTT Docomo) with a gp revolution phone running cm11 and not having much luck. The phone picks up the carrier spinning for a minute or more on the "mobile operators" page, but when I select "jp docomo" it shows the "registering on JP DOCOMO" for ages and finally fails to connect.

Not sure if this is a hardware or network issue, but I've connected to the same network using the same sim on another "unconventional" phone (open zte running firefox os) without any issues, so I suspect the phone.

Any help would be much appreciated.

Offline shioyama

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
  • Karma: 0
    • View Profile
    • dejimata
Re: gp revolution fails to connect to Japan carrier NTT docomo
« Reply #1 on: June 14, 2015, 01:53:12 AM »
I thought perhaps it could be a frequency band issue, but both phones say they support the same bands:

The ZTE Open operates on UMTS/HSPA bands 850, 900, 1900, 2100 MHz (ref: http://www.engadget.com/products/zte/open/specs/)

The gp revolution operates on HSPA/WCDMA 850, 900, 1900, 2100 MHz (ref: http://shop.geeksphone.com/en/phones/9-revolution.html)

Reference on Japanese mobile frequency bands: http://www.japanmobiletech.com/2012/03/japanese-mobile-frequency-bands.html:

I checked this before buying the phone which is why I thought it would work.