Author Topic: Keon won't charge and is not recognized when plugged in to the PC?  (Read 1007 times)

Offline Vita

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
  • Karma: 0
    • View Profile
Hi,

I had my developer preview phone. It worked great for about 6 months, and then it didn't want to charge anymore. The battery drained totally, and I thought that the battery was causing the problem. I managed to charge the battery externally and then the phone starts.

The problem is when I plug the USB to the computer, the phone even does not recognize it is plugged in, also my computer does not notify me about a new device, as if the phone is not plugged in. It doesn't even charge via USB or charger, I tried flashing it to android even, but the problem is still the same. Now I can't even get it back to default ROM.

The weird thing is when the phone is off, and I plug the USB from the charger the phone starts up, but does not charge. I thought that was a software bug, but reflashing ROM didn't help, so I thing it's something with the USB.

If anyone has any info about the hardware, schematics, teardown pictures or video, please post them here so I could try to fix the problem.

Thanks in advance!