Geeksphone Forum

International Forum => (gp) One => Topic started by: Simon on January 21, 2011, 03:33:03 AM

Title: Hear nothing in phonecalls. Plus no ringing on incomming calls/alarms [RCMod304]
Post by: Simon on January 21, 2011, 03:33:03 AM
hey,

Here's my problem:
I don't hear anything when I'm in a phonecall, nor does the other person hear me!
Additionally the phone does not make a single move/sound when it's supposed to be ringing.

What is not the problem:
The speaker itself, as other sounds/beeps/music is working fine.
I hardly think it's a hardware issue, as I just got the phone from repair and it seems to be in pretty good shape now(thanks a lot Javier and GP-team!!)

When did it occur:
Actually, when I changed country, I arrived in Egypt 3 days ago, since then the problem is present. I have no idea if it could be a network issue, is that technically possible?

What I tried:
reinstalling RCMod304 from recovery, did not change a thing. Wiping neither.


Any ideas what to do?
Title: Re: Hear nothing in phonecalls. Plus no ringing on incomming calls/alarms [RCMod304]
Post by: Simon on January 21, 2011, 09:36:20 PM
Today I reflashed using RUT to stock ROM 51. That did not change it(at least the in-call issue, didn't try the alarm).

As far as I see it (please correct me if I'm wrong), that limits the possibilities to (a) harrdware or (b) network issue.

Network as a cause seems somehow likely as the problem arised when I arrived in Egypt. Does anybody have a clue if that makes sense? Shall I try a different operator?

Thanks

Simon
Title: Re: Hear nothing in phonecalls. Plus no ringing on incomming calls/alarms [RCMod304]
Post by: Javier (gp) on January 22, 2011, 02:24:14 AM
Well, it seems possible, happened be before but with a different phone (not smartphone). If you can try a different SIM it would be nice
Title: Re: Hear nothing in phonecalls. Plus no ringing on incomming calls/alarms [RCMod304]
Post by: Simon on January 25, 2011, 11:16:51 AM
Summary of the last 20hrs:
(1) MobiNIL SIM-Cards didn't work for me
(2) Vodafone EG works fine
(3) Revolution in Egypt
Title: Re: Hear nothing in phonecalls. Plus no ringing on incomming calls/alarms [RCMod304]
Post by: bmorales on January 27, 2011, 06:48:50 AM
Hi,

I had this very same problem also. The speaker ramdomly stopped working for calls.

I had to reboot in order to use the phone for calling, and the test the speaker by calling provider (a free call just to test if the speaker were working :) )

I had no more problem after I updated to de RCMOD4. I updated to the CG 6.1 and still no more problems about it.

I hope it helps. Greetings.
Title: Re: Hear nothing in phonecalls. Plus no ringing on incomming calls/alarms [RCMod304]
Post by: lascienceinculte on February 21, 2011, 12:24:55 PM
Hi,

I've got the same problem.
No sound during calls, at the beginning only during landlines calls, then also with cellular one.
I've try to fix it by upgrading my phone to Rcmod 4 but it did not works for me.
Sim card works perfectly in my old phone. Reboot my phone don't fix the issue.
I think the only solution is to erase all to factory settings but I've got some data I don't want to loose.
What should I do to back up  some data like contacts, SMS etc.

Thanks.  ;D

Title: Re: Hear nothing in phonecalls. Plus no ringing on incomming calls/alarms [RCMod304]
Post by: Simon on February 23, 2011, 12:16:36 AM
I've try to fix it by upgrading my phone to Rcmod 4 but it did not works for me.
What do you mean by that? Was the upgrade problematic or did it go through but not change the problem?

I think the only solution is to erase all to factory settings but I've got some data I don't want to loose.
As sad as that sounds, for me, "wiping" the phone did not change anything... the only thing that was effective was changing sim-card(and network provider)

What should I do to back up  some data like contacts, SMS etc.
Dunno, maybe searching the market for "backup" is a good start!

Thanks.  ;D
You're most welcome!
Title: Re: Hear nothing in phonecalls. Plus no ringing on incomming calls/alarms [RCMod304]
Post by: lascienceinculte on February 23, 2011, 09:54:09 AM
What do you mean by that? Was the upgrade problematic or did it go through but not change the problem?
Upgrade to RcMod4 was a complete success but it don't  change the problem.

As sad as that sounds, for me, "wiping" the phone did not change anything... the only thing that was effective was changing sim-card(and network provider)
what mean "wiping" the phone. For the moment I can't change my provider.


Title: Re: Hear nothing in phonecalls. Plus no ringing on incomming calls/alarms [RCMod304]
Post by: benmachine on June 20, 2011, 03:36:18 AM
I'm also having this problem, but I haven't changed networks recently, or anything else about my phone. Restoring from an earlier backup has had no noticeable effect.

Luckily I did have a spare SIM card around and it does seem to work (I could only test the free how-much-credit-do-I-have number, since that SIM card doesn't have any money on it). I'd like my old SIM card to work like it used to, though. What can I do?

Edit: okay, here's the behaviour I see in more detail:
After turning on the phone, music, alarms, menu noises all work fine. I left my music playing and tried my credit number. It was silent, but when I hung up the music continued where it had left off. Then I turned my music off, and tried my credit number again. It was silent, and furthermore when I hung up, all sound stopped. The dialling keypad no longer makes sound, alarms vibrate but make no noise. The music player refuses to play – the cursor indicating current position never moves, regardless of if I pause it or unpause it. I can move it to different parts of the song, but it still never plays or makes any sound at all.

This is on RCMod 4.0.0
Title: Re: Hear nothing in phonecalls. Plus no ringing on incomming calls/alarms [RCMod304]
Post by: l_eon on August 10, 2011, 12:23:10 AM
on our russian forum people say, that same problem with the sound shows itself only on few devices.
so i think it is hardware problem.
i have that problem on each RCmod from RCMod 2.1.x and above.

one comrade suggested to install standart settings apk

here is the original quote


Попробовать стандартный Settings.

adb pull Settings.apk /system/app/Settings.apk
где Settings.apk - родной из офф прошивки.


Try standart settings file.
adb pull Settings.apk /system/app/Settings.apk
where Settings.apk - is from the original firmware


i installed that file with the help of file browser, not with adb(i have no how to idea how to use adb)
it did'nt help at all.