Author Topic: Problema: Ubuntu no me detecta el teléfono para ADB (SOLUCIONADO)  (Read 11858 times)

mmo_gpf

  • Guest
Pues eso, la primera en la frente.

Conecto el ZERO por el cable USB al portatil (Ubuntu 10.10) y no me detecta el teléfono para usar adb: ./adb devices

root@zzb-yvahk:/home/mmo/android_sdk/tools# ./adb devices
List of devices attached

root@zzb-yvahk:/home/mmo/android_sdk/tools#


Sin embargo la HTC Magic, si la conecto:
root@zzb-yvahk:/home/mmo/android_sdk/tools# ./adb devices
List of devices attached
HT95ZKF07060   device

root@zzb-yvahk:/home/mmo/android_sdk/tools#


Tengo habilitado la depuración de aplicaciones, y al conectar salen los iconos de la unidad USB y de la depuración
¿qué estoy haciendo mal?

Saludos y gracias

« Last Edit: April 26, 2011, 07:40:20 AM by mmo_gpf »

Offline aitorTheRed

  • Administrator
  • Top Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1631
  • Karma: 58
    • View Profile
    • Ich Weiss nicht
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #1 on: April 26, 2011, 06:35:41 AM »
Mmm, raro.... yo no he tenido ningún problema al conectarlo a ubuntu...

Prueba a conectarlo a otro USB (just in case), y también prueba a hacer lsusb con el teléfono conectado, y sin él (a ver si hay alguna diferencia entre las dos).
I'm not Geeksphone Staff. Only Forum Administrator.
"Los README son para los gallinas. Se valiente y ejecuta"
Follow me on twitter! http://twitter.com/#!/aitorTheRed

Offline slok

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 132
  • Karma: 10
    • View Profile
    • My twitter
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #2 on: April 26, 2011, 06:42:00 AM »
Puedes probar con un "dmesg" a ver si lo detecta bien el kernel al engancharlo. ¿Que SDK tienes?



Offline silverius

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 293
  • Karma: 0
    • View Profile
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #3 on: April 26, 2011, 06:43:44 AM »
Has hecho estos pasos?

http://wiki.geeksphone.com/es/index.php?title=Conectar_con_adb_en_GNU/Linux

yo en Arch tuve que editar /etc/udev/rules.d/50-android.rules (en mi caso 80-android.rules)

Saludos
GP1 rulando SuperAOSP 8.6

mmo_gpf

  • Guest
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #4 on: April 26, 2011, 06:49:43 AM »
Mmm, raro.... yo no he tenido ningún problema al conectarlo a ubuntu...

Prueba a conectarlo a otro USB (just in case), y también prueba a hacer lsusb con el teléfono conectado, y sin él (a ver si hay alguna diferencia entre las dos).

Con el ZERO conectado:

root@zzb-yvahk:/home/mmo/android_sdk/tools# lsusb
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 0461:4d15 Primax Electronics, Ltd Dell Optical Mouse
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications Processor
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 010: ID 05c6:9018 Qualcomm, Inc.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0c45:63f0 Microdia
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@zzb-yvahk:/home/mmo/android_sdk/tools#


Sin él:

root@zzb-yvahk:/home/mmo/android_sdk/tools# lsusb
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 0461:4d15 Primax Electronics, Ltd Dell Optical Mouse
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications Processor
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0c45:63f0 Microdia
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@zzb-yvahk:/home/mmo/android_sdk/tools#


Hay un "Bus 002 Device 010: ID 05c6:9018 Qualcomm, Inc." de diferencia.

Saludos

Offline aitorTheRed

  • Administrator
  • Top Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1631
  • Karma: 58
    • View Profile
    • Ich Weiss nicht
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #5 on: April 26, 2011, 06:55:34 AM »
Tu ID es 05c6:9018
Prueba a seguir los pasos del link de la wiki que te ha puesto silverius
http://wiki.geeksphone.com/es/index.php?title=Conectar_con_adb_en_GNU/Linux
con ese ID, a ver si conseguimos que funcione ;)
I'm not Geeksphone Staff. Only Forum Administrator.
"Los README son para los gallinas. Se valiente y ejecuta"
Follow me on twitter! http://twitter.com/#!/aitorTheRed

Offline Juanan

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 140
  • Karma: 8
    • View Profile
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #6 on: April 26, 2011, 06:58:08 AM »
¿Has mirado si tienes la opción de Depuración USB activada? creo que si no lo está el ADB no lo detecta... la opción está en "Ajustes / Aplicaciones / Desarrollo"

mmo_gpf

  • Guest
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #7 on: April 26, 2011, 07:01:50 AM »
¿Has mirado si tienes la opción de Depuración USB activada? creo que si no lo está el ADB no lo detecta... la opción está en "Ajustes / Aplicaciones / Desarrollo"

Está en el primer post, donde decía que lo tenía habilitado.

Saludos

mmo_gpf

  • Guest
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #8 on: April 26, 2011, 07:03:58 AM »
Tu ID es 05c6:9018
Prueba a seguir los pasos del link de la wiki que te ha puesto silverius
http://wiki.geeksphone.com/es/index.php?title=Conectar_con_adb_en_GNU/Linux
con ese ID, a ver si conseguimos que funcione ;)

Estoy siguiendo esos pasos. Yo tenía un "11-android.rules" creado para la Magic con la línea:
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0bb4", ATTRS{idProduct}=="0c02", MODE="0666", OWNER="mmo"

He añadido lo mismo con los datos del ZERO:
SUBSYSTEMS=="usb", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9018", MODE="0666", OWNER="mmo"

¿He puesto bien el vendor y el producto no?

He reiniciado los servicios del udev...pero nada...

Saludos

mmo_gpf

  • Guest
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #9 on: April 26, 2011, 07:09:10 AM »
Tu ID es 05c6:9018
Prueba a seguir los pasos del link de la wiki que te ha puesto silverius
http://wiki.geeksphone.com/es/index.php?title=Conectar_con_adb_en_GNU/Linux
con ese ID, a ver si conseguimos que funcione ;)

He probado con:

SUBSYSTEM=="usb", SYSFS{idVendor}=="05c6", MODE="0666"

Y tampoco :( :( :(

Saludos

Offline silverius

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 293
  • Karma: 0
    • View Profile
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #10 on: April 26, 2011, 07:13:03 AM »
Tu ID es 05c6:9018
Prueba a seguir los pasos del link de la wiki que te ha puesto silverius
http://wiki.geeksphone.com/es/index.php?title=Conectar_con_adb_en_GNU/Linux
con ese ID, a ver si conseguimos que funcione ;)

He probado con:

SUBSYSTEM=="usb", SYSFS{idVendor}=="05c6", MODE="0666"

Y tampoco :( :( :(

Saludos

Yo creo que lo que tienes que poner es:

SUBSYSTEM=="usb", SYSFS{idVendor}=="9018", MODE="0666"
GP1 rulando SuperAOSP 8.6

mmo_gpf

  • Guest
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #11 on: April 26, 2011, 07:13:10 AM »
Puedes probar con un "dmesg" a ver si lo detecta bien el kernel al engancharlo. ¿Que SDK tienes?


root@zzb-yvahk:/home/mmo/android_sdk/tools# ./adb version
Android Debug Bridge version 1.0.25
root@zzb-yvahk:/home/mmo/android_sdk/tools#

¿Es vieja? ¿Puedo mejorarla?

Saludos

mmo_gpf

  • Guest
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #12 on: April 26, 2011, 07:15:15 AM »
Tu ID es 05c6:9018
Prueba a seguir los pasos del link de la wiki que te ha puesto silverius
http://wiki.geeksphone.com/es/index.php?title=Conectar_con_adb_en_GNU/Linux
con ese ID, a ver si conseguimos que funcione ;)

He probado con:

SUBSYSTEM=="usb", SYSFS{idVendor}=="05c6", MODE="0666"

Y tampoco :( :( :(

Saludos

Yo creo que lo que tienes que poner es:

SUBSYSTEM=="usb", SYSFS{idVendor}=="9018", MODE="0666"

No ha funcionado ¿?¿?¿?

Saludos

Offline slok

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 132
  • Karma: 10
    • View Profile
    • My twitter
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #13 on: April 26, 2011, 07:18:40 AM »
Yo tengo una superior (Tengo el SDK 10)
Code: [Select]
slok@sLoKPC:platform-tools$ adb version 
Android Debug Bridge version 1.0.26

Edit: prueba a actualizarlo. Aunque el problema persista, así tendras todo actualizado :)



mmo_gpf

  • Guest
Re: Problema: Ubuntu no me detecta el teléfono para ADB
« Reply #14 on: April 26, 2011, 07:20:52 AM »
Yo tengo una superior (Tengo el SDK 10)
Code: [Select]
slok@sLoKPC:platform-tools$ adb version 
Android Debug Bridge version 1.0.26

Edit: prueba a actualizarlo. Aunque el problema persista, así tendras todo actualizado :)

Dudo que sea por eso....el adb es más sencillo que un zapato :) :) :)

No se....

Saludos y gracias por la ayuda