Author Topic: Updates stuck at 2015-04-07  (Read 21200 times)

Offline knezi

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 10
  • Karma: 0
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #75 on: September 27, 2015, 01:10:16 PM »
mossroy,
Ok. Thank you. I wanted to compile something more stable and usable. How usable is current master?

Offline helmar

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 3
  • Posts: 26
  • Karma: 4
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #76 on: October 06, 2015, 07:51:16 AM »
Ok. Thank you. I wanted to compile something more stable and usable. How usable is current master?
Master is quite usable. After playing around with the developer settings it works quite stable on my Peak, but I did not find out exactly which option causes crashes or avoids them.

I noticed two bugs: The external SD card is not accessible via USB (mass storage) and i cannot turn on bluetooth.

But I do not use the phone as my regular phone, only as a playground.

Helmar.

Offline helmar

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 3
  • Posts: 26
  • Karma: 4
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #77 on: November 07, 2015, 03:08:23 AM »
You can find my B2G (Foxfood) builds for the Geeksphone Peak on

http://www.gerloni.net/gp-peak/

Currently there is only one B2G master build, but i will upload new versions from time to time and maybe also make v2.5 images. The image contains all language packs and i tried to optimize the dev settings to avoid screen artefacts (the tiles seem to cause them). The external SD card is still not accessible via USB (mass storage) and i cannot turn on bluetooth, but beside that the image is quite stable and usable.

For flashing i took over the scripts and binaries provided by Geeksphone in their latest official builds.

Helmar.

Follow members gave a thank to your post:


Offline bdcomp

  • Jr. Member
  • **
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 62
  • Karma: 1
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #78 on: November 08, 2015, 08:13:13 AM »
You can find my B2G (Foxfood) builds for the Geeksphone Peak on

http://www.gerloni.net/gp-peak/

Currently there is only one B2G master build, but i will upload new versions from time to time and maybe also make v2.5 images. The image contains all language packs and i tried to optimize the dev settings to avoid screen artefacts (the tiles seem to cause them). The external SD card is still not accessible via USB (mass storage) and i cannot turn on bluetooth, but beside that the image is quite stable and usable.

For flashing i took over the scripts and binaries provided by Geeksphone in their latest official builds.

Helmar.

Helmar,

Thanks for compiling the master image and for the link.

A stable image (v2.5 probably) will be much appreciated.

Thanks again!
« Last Edit: November 10, 2015, 12:25:48 AM by bdcomp »

Offline rick110

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 21
  • Karma: 0
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #79 on: November 12, 2015, 01:57:14 AM »
@helmar:

With your Image and my own ones the SIM-Card is not found.

Using the Android-Image no issue occurs.

Has anybody else this problem - or maybe a solution?

regards, Rick

Offline helmar

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 3
  • Posts: 26
  • Karma: 4
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #80 on: November 17, 2015, 09:32:00 AM »
@helmar:

With your Image and my own ones the SIM-Card is not found.

Using the Android-Image no issue occurs.

Has anybody else this problem - or maybe a solution?

regards, Rick
Hi Rick,

currently I have no SIM card in the phone, but I will test that at the next opportunity. My Peak is not in best shape any more, you know, the battery problem... If anyone out there could sell me his Peak or Keon for a few bucks I would be interested.

A stable image (v2.5 probably) will be much appreciated.
bdcomp,

I built some older stable images. 1.4 seems to be mostly complete and stable, 2.1 not so much. 2.2 did not build (I ran into https://bugzilla.mozilla.org/show_bug.cgi?id=1121600).

I also tried to build 2.5, but the result was exacly the same as master, so the branch seems not to be ready yet.

You can also find my build script in http://www.gerloni.net/gp-peak/ . I use it to build all the images I upload. Don't know if it is good or bad; any feedback is appreciated.

Regards,    Helmar.

Offline Djan

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 1
  • Posts: 93
  • Karma: 3
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #81 on: November 24, 2015, 01:55:12 AM »
Hello,

Does anyone know a script to backup/recover via adb contacts and SMS's?
There use to be one but sinds 2.2 it does not work anymore because the folder structure changed.

It's for me needed prior to test the master image.

Thanks in advance.

Offline knezi

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 10
  • Karma: 0
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #82 on: November 24, 2015, 11:35:01 AM »
Quote
@Djan
Does anyone know a script to backup/recover via adb contacts and SMS's?
Can you link this script? I can update it, but did not see this script.

@Helmar
Thanks to your build. For other users, just note that the provided script build_B2G by Helmar for the first run creates directory in PWD and you have to then move this script manually into this before you can update it.
Tried today (24.11) and build failed because NSModule were not ordered appropriately - common bug.


Offline Djan

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 1
  • Posts: 93
  • Karma: 3
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #83 on: November 26, 2015, 12:13:28 AM »
@knezi

The script is there: https://gist.github.com/noreiller/b8fa730b6ab3a5b6c33c

See this post: http://forum.geeksphone.com/index.php?topic=6299.msg65554#msg65554

One change I found is that the folder "persistent" is renamed to "permanent". But there may be new changes.

Another problem was the use of "BACKUP_DATE=`date +%Y-%m-%d_%H-%M-%S`" in both backup and restore scripts: it work well for the backup but when you restore, it uses the actual time and does not find the backup folder, sinds the time changed between. I simplified it with the use of "BACKUP_DATE=`date +%Y-%m-%d`" (see there)

Offline Djan

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 1
  • Posts: 93
  • Karma: 3
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #84 on: December 02, 2015, 12:45:11 AM »

Offline Djan

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 1
  • Posts: 93
  • Karma: 3
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #85 on: December 09, 2015, 01:41:49 AM »
@helmar

I installed your master image yesterday (image dated of the 3 Dec 2015) and I must give you a big thank. It works much better than the last 2.2 image from GP. The graphical artefacts are dramatically reduced and everything seems much more fluent.

The only regression is the Bluetooth that does not work but you mentioned it already.

Edit - second bug : wifi connection is not very stable. When it wakes up, it says it's connected but nothing can be downloaded. You have to connect to another wifi and then back to your first wifi to make it work. Turning off/on wifi may also work but I didn't try.This was a problem of my local wifi, not of your ROM.
« Last Edit: December 12, 2015, 01:30:07 AM by Djan »

Offline a-dead-trousers

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 5
  • Posts: 38
  • Karma: 5
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #86 on: December 13, 2015, 12:49:40 PM »
hi@all

As for accessing the SD-Card via USB you have to name it the same in /etc/vold.origin.fstab and /system/etc/vold.fstab.
Because of bug https://bugzilla.mozilla.org/show_bug.cgi?id=1090271 the only possible names are "sdcard1", "extsdcard" or "external"

I went for "sdcard1" in both /etc/vold.origin.fstab and /system/etc/vold.fstab
Code: [Select]
dev_mount sdcard1 /mnt/emmc   auto /devices/platform/msm_sdcc.1/mmc_host
dev_mount sdcard  /mnt/sdcard 18   /devices/platform/msm_sdcc.3/mmc_host

wkr ADT

Follow members gave a thank to your post:


Offline Djan

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 1
  • Posts: 93
  • Karma: 3
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #87 on: January 05, 2016, 12:34:17 PM »
Hello.
I tried to update to the masterbuild of helmar of 2016-01-01 and I got a series of "fastboot: permission denied".
No way to flash the image.
I tried "adb remount" and "adb root" without success. Any idea?

Thanks.

---
Edit: There seem to be a problem with the adb in the archive. I changed in the script the "./fastboot" to "fastboot" (and same with adb) to use the binaries of my linux system and I could flash it. Strange...
« Last Edit: January 05, 2016, 12:52:25 PM by Djan »

Offline Djan

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 1
  • Posts: 93
  • Karma: 3
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #88 on: January 05, 2016, 12:57:10 PM »
I found this weird and annoying bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1234532
"April 2016 displayed as March 2016"

Can anyone confirm if it occurs on your phones as well?

Offline helmar

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 3
  • Posts: 26
  • Karma: 4
    • View Profile
Re: Updates stuck at 2015-04-07
« Reply #89 on: January 06, 2016, 12:49:32 AM »
Hello.
I tried to update to the masterbuild of helmar of 2016-01-01 and I got a series of "fastboot: permission denied".
No way to flash the image.
I tried "adb remount" and "adb root" without success. Any idea?

Thanks.

---
Edit: There seem to be a problem with the adb in the archive. I changed in the script the "./fastboot" to "fastboot" (and same with adb) to use the binaries of my linux system and I could flash it. Strange...
Hi Djan,

i had that problem too, if i remember well. This was because i did an "adb shell" or similar before flashing, so the adb daemon installed on the system was running and collided with the adb binary from the zip file. Try to do "killall adb" before flashing,

Helmar.